Jump to content

Infinite Load on Create a Show


rynebrandon
 Share

Recommended Posts

This happened to me once before and I rolled my game back to a much older save in order to fix it. Good lord, I would prefer not to do it again if I can avoid it.

Somewhere along the way, my game got corrupted such that when I edit the "Load show" or the "transitions" for a create-a-show, the game ends up in an infinite loading screen with the red loading indicator flickering red in the bottom right hand corner. Has anyone encountered this? Does anyone know how to address it?

Edited by rynebrandon
Link to comment
Share on other sites

29 minutes ago, rynebrandon said:

This happened to me once before and I rolled my game back to a much older save in order to fix it. Good lord, I would prefer not to do it again if I can avoid it.

Somewhere along the way, my game got corrupted such that when I edit the "Load show" or the "transitions" for a create-a-show, the game ends up in an infinite loading screen with the red loading indicator flickering red in the bottom right hand corner. Has anyone encountered this? Does anyone know how to address it?

Issues like this are usually due to a corrupt gamesave file.

Link to comment
Share on other sites

I just rolled back to my first gamesave after a clean re-install a week ago. I was definitely not having this problem then. It didn't resolve the issue. 

Is there a specific behavior that would cause the gamesave to corrupt? Literally all I've been doing is loading and testing mods. I haven't actually progressed in my universe and done anything meaningful in the game. 

Link to comment
Share on other sites

1 minute ago, rynebrandon said:

I just rolled back to my first gamesave after a clean re-install a week ago. I was definitely not having this problem then. It didn't resolve the issue. 

Is there a specific behavior that would cause the gamesave to corrupt? Literally all I've been doing is loading and testing mods. I haven't actually progressed in my universe and done anything meaningful in the game. 

Its hard to pinpoint what causes a gamesave to get corrupt  but its definitely happens with mods added to the game .On one occasion, I had to start off with a fresh save to resolve the issue. 

Link to comment
Share on other sites

Ok, I think I figured out the cause (or at least I strongly suspect I do). This appears to be connected to downloading material from community creations. Both times this has happened to me, I tried to download a superstar from community creations only to get the "Download Failed, This Content is Damaged" error (or however it's phrased). 

So, you were right. It is associated with the SAVEDATA files.

I realize now that I wasn't actually rolling my save back because I wasn't going into offline mode, so even though I thought I was swapping in and out save games, it turns out Steam was just pulling down my information from the cloud.

FOR ANYONE IN THE FUTURE: don't be a moron like me and think you're rolling back to a previous save when you aren't actually. Make sure you follow these directions carefully when rolling back to a previous save: https://smacktalks.org/wiki/index.php/Installing_Mods#Backup_your_save_game_directory

By default, CCT keeps backups of all your save games, so if you ever get the "Download Failed, This Content is Damaged" just know that that save file is probably borked. Close the program, follow the directions above and roll back to a previous save. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...