TheVisitorX

Custom Character Tools 2019 [Released: Version 1.3.1.0 Beta]

Recommended Posts

BlackBen83
14 hours ago, vigymuh said:

i wouldn't do the verify the integrity since it messes up all of my mods and i have to re apply all of them one by one. i have done that once and i regretted it so much.

i think imma just wait for the CCT update and hope it fixes everything.

@vigymuh Yeah I understand, I'll try to see this evening if my crash doesn't came from the last pac.mod I have installed (Silas Young from Bannock), but I'm not sure. I need to do some try, perhaps I'm wrong ^^ I haven't no problem with Bannock Jay Lethal so why Silas ^^.

I tell you if I success to fix the problem of my game crash.

@TheVisitorX Sorry to disturb you brother, have you any date for the released? Just for information.

Thanks a million for your work, as usual, really important for the game :)

Share this post


Link to post
Share on other sites
TheVisitorX

Well, if it is actually a crash due to a bad render, then there will be a fix as soon as I found the cause (I currently have no PAC files, which lead to the above problem). If the crashes have other causes and there are many possible causes (CH-Pac file is faulty, titantron, mini or walltron has wrong format, etc.) I can't fix anything there. Please, if you report errors related to CCT (especially crashes in the game), please test it on a new and clean save without mods. If you have several things installed at the same time, then in the end, no one can say or pinpoint what really causes the issue. If someone has a render that demonstrably crashes, please send me the PAC file, not the dds file. That the render is not shown in some places will be fixed.

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
BlackBen83
1 hour ago, TheVisitorX said:

Well, if it is actually a crash due to a bad render, then there will be a fix as soon as I found the cause (I currently have no PAC files, which lead to the above problem). If the crashes have other causes and there are many possible causes (CH-Pac file is faulty, titantron, mini or walltron has wrong format, etc.) I can't fix anything there. Please, if you report errors related to CCT (especially crashes in the game), please test it on a new and clean save without mods. If you have several things installed at the same time, then in the end, no one can say or pinpoint what really causes the issue. If someone has a render that demonstrably crashes, please send me the PAC file, not the dds file. That the render is not shown in some places will be fixed.

@TheVisitorX Thanks for all brother, 

I have refresh my game, re-test, and re-inject trons step by step, all the content game works fine :) (the KUSHIDA new tron too).

You're right only some renders doesn't appeared in game, but it's not a problem when they don't appreared. I've located some renders which aren't worked for the moment, like Ryan Reeves, Brian Cage, Fabian Aichner (curiously an original that I have used for my last caw) or again Vampiro and new NXT Kushida. But it's a detail and I have only my personnal DDS :( 

Thanks a lot for all yours advices, and your work.

I can't wait the final release :D 

Have a nice day.

Ben

Share this post


Link to post
Share on other sites
TheVisitorX
8 minutes ago, BlackBen83 said:

@TheVisitorX Thanks for all brother, 

I have refresh my game, re-test, and re-inject trons step by step, all the content game works fine :) (the KUSHIDA new tron too).

You're right only some renders doesn't appeared in game, but it's not a problem when they don't appreared. I've located some renders which aren't worked for the moment, like Ryan Reeves, Brian Cage, Fabian Aichner (curiously an original that I have used for my last caw) or again Vampiro and new NXT Kushida. But it's a detail and I have only my personnal DDS :( 

Thanks a lot for all yours advices, and your work.

I can't wait the final release :D 

Have a nice day.

Ben

So you can't see the render in the game, it is completely blank, right?

The game / oodl file format seems to have problems with some dds files - Please make sure to create/convert your dds render images with paint.net and it should work.

I haven't found out yet why that happens. I've never had that problem before with the 'old' zlib file format.

If the default render appeared instead of the modded one, it's a caching/race-condition issue - That one needs a fix!

Edited by TheVisitorX
  • Like 1

Share this post


Link to post
Share on other sites
BlackBen83
27 minutes ago, TheVisitorX said:

So you can't see the render in the game, it is completely blank, right?

The game / oodl file format seems to have problems with some dds files - Please make sure to create/convert your dds render images with paint.net and it should work.

I haven't found out yet why that happens. I've never had that problem before with the 'old' zlib file format.

If the default render appeared instead of the modded one, it's a caching/race-condition issue - That one needs a fix!

In fact I see my old renders, as the new renders injected in this place doesn't appeared sometime. But when I relaunch the game, they appear ^^, I haven't blanck renders. And I work all my custom renders with Paint.net without problem :)

So I think like you write "If the default render appeared instead of the modded one, it's a caching/race-condition issue - That one needs a fix!"

Just some examples :) 

Here after rehash and resign with CCT, KUSHIDA and Silas Young works fine, but Marcel Barthel doesn't appears :D 

Quote

ug90q80cnnzcx8lzg.jpg

o73oi399v956xdrzg.jpg

9gfjwqwg5pl24uszg.jpg

Edited by BlackBen83

Share this post


Link to post
Share on other sites
TheVisitorX

 

1 hour ago, BlackBen83 said:

In fact I see my old renders, as the new renders injected in this place doesn't appeared sometime. But when I relaunch the game, they appear ^^, I haven't blanck renders. And I work all my custom renders with Paint.net without problem :)

So I think like you write "If the default render appeared instead of the modded one, it's a caching/race-condition issue - That one needs a fix!"

Just some examples :) 

Here after rehash and resign with CCT, KUSHIDA and Silas Young works fine, but Marcel Barthel doesn't appears :D 

o73oi399v956xdrzg.jpg

9gfjwqwg5pl24uszg.jpg

Yes, this is a game of chance. Sometimes it will work, sometimes not. I'm just about to fix that for the Render-Injector. Should go live pretty soon.

Edited by TheVisitorX
  • Thanks 1

Share this post


Link to post
Share on other sites
TheVisitorX

1.3.1.0 has been released.

Changes in this version:

Fixed:

- Render hasn't changed in the game (hopefully fixed, please leave feedback!)
- Wrong compressed size in OODL file header (Thank you @pozzum)

The new render injection is the same process as in earlier versions, so that means it changes the id in the ltag files before applying a new render. You have to install all renders again via CCT to apply this 'fix'. Hopefully it will help...

Edited by TheVisitorX
  • Too Sweet 1
  • Thanks 2

Share this post


Link to post
Share on other sites
BlackBen83
13 minutes ago, TheVisitorX said:

1.3.1.0 has been released.

Changes in this version:

Fixed:

- Render hasn't changed in the game (hopefully fixed, please leave feedback!)
- Wrong compressed size in OODL file header (Thank you @pozzum)

The new render injection is the same process as in earlier versions, so that means it changes the id in the ltag files before applying a new render. You have to install all renders again via CCT to apply this 'fix'. Hopefully it will help...

@TheVisitorX Wow incredible, thanks a lot to you two guyz. Really, really appreciate your work.

I'll try now, I'll leave feedback, thanks again.

Ben

  • Thanks 1

Share this post


Link to post
Share on other sites
BlackBen83

@TheVisitorX I note something, my last rendered / modded superstars I have tried to install are the following :

- Brian Cage, Eli Drake, Fabian Aichner, Jay Lethal, Kota Ibushi, KUSHIDA, Marcel Barthel, Rich Swann, Silas Young and Vampiro.

When Brian Cage, Eli Drake, KUSHIDA, Kota Ibushi, Rich Swann are installed, the others are original or last renders I have injected for others mods. And if I re-install the others, Brian Cage, Eli Drake, KUSHIDA, Kota Ibushi and Rich Swann again become original renders (rehash and resign).

I've also trying to install all of them at one time, but I encounter the same problem. Perhaps one of my .DDS aren't good?

Or I need to delete something in the game folders who is corrupted?

 

Oh I encounter again the renders problem with the blanck Adam Cole, and the non rendered Hanson (War Raiders). Sometimes it's good, sometimes not.

Sorry for those news :( 

And thanks again for your work.

Edited by BlackBen83

Share this post


Link to post
Share on other sites
Cave Waverider
7 hours ago, BlackBen83 said:

@TheVisitorX I note something, my last rendered / modded superstars I have tried to install are the following :

- Brian Cage, Eli Drake, Fabian Aichner, Jay Lethal, Kota Ibushi, KUSHIDA, Marcel Barthel, Rich Swann, Silas Young and Vampiro.

When Brian Cage, Eli Drake, KUSHIDA, Kota Ibushi, Rich Swann are installed, the others are original or last renders I have injected for others mods. And if I re-install the others, Brian Cage, Eli Drake, KUSHIDA, Kota Ibushi and Rich Swann again become original renders (rehash and resign).

I've also trying to install all of them at one time, but I encounter the same problem. Perhaps one of my .DDS aren't good?

Or I need to delete something in the game folders who is corrupted?

 

Oh I encounter again the renders problem with the blanck Adam Cole, and the non rendered Hanson (War Raiders). Sometimes it's good, sometimes not.

Sorry for those news :( 

And thanks again for your work.

Is that with the new version 1.3.1.0? Also, it would likely be helpful if you shared the SlotID and SlotNumber for the ones you've tried to install, maybe there is a pattern to be found with those.

Share this post


Link to post
Share on other sites
BlackBen83
3 hours ago, Cave Waverider said:

Is that with the new version 1.3.1.0? Also, it would likely be helpful if you shared the SlotID and SlotNumber for the ones you've tried to install, maybe there is a pattern to be found with those.

@Cave Waverider @TheVisitorX Yes It's with the last update 1.3.1.0 :) I've left feedback so that you are informed of the situation that I met with the new updated CCT.

- Brian Cage : SN 129 , ID 160 : Batista'10

- Eli Drake : SN 349 - ID 626 : Finn Balor Demon

- Fabian Aichner : SN 248 - ID 451 : Jey Uso'14

- Jay Lethal : SN 247 - ID 450 : Kane'12

- Kota Ibushi : SN 256 - ID 459 : Chris Jericho'10

- KUSHIDA : SN 328 - ID 591 : Ricky Steamboat

- Marcel Barthel : SN 155 - ID 254 : Ultimate Warrior

- Rich Swann : SN 242 - ID 443 : Randy Orton'13 (attire 1)

- Silas Young : SN 214 - ID 392 : Jake the Snake Roberts

- Vampiro : SN 423 - ID 764 : El Mago :) 

Hope it can help, and thanks a lot.

 

 

Oh I have launch the game this morning to try again, but Adam Cole is again blanck (in render game) and crashed the game when it's selected (just for info).

Have a nice day,

Ben

Edited by BlackBen83

Share this post


Link to post
Share on other sites
TheVisitorX

Please try to delete your whole CCT mod directory and install all renders and things again (re-generate your chunk cache before you do this). Make sure that you haven't any other render mods installed from other sources which could interfere with the renders used from CCT. That the render of Cole is blank makes no sense to me. He has a completely different slot id. Sure, you did not accidentally replace it with a wrong dds file?

Edited by TheVisitorX
  • Like 1

Share this post


Link to post
Share on other sites
Clarityman
8 hours ago, TheVisitorX said:

Please try to delete your whole CCT mod directory and install all renders and things again (re-generate your chunk cache before you do this). Make sure that you haven't any other render mods installed from other sources which could interfere with the renders used from CCT. That the render of Cole is blank makes no sense to me. He has a completely different slot id. Sure, you did not accidentally replace it with a wrong dds file?

This was going to be my exact advice too. I've had zero problems with the 1.3.0.0 update because I just deleted any conflicting renders from the mods folder, and installed updated renders with the newer method. It's worked flawlessly.

I'm actually holding off installing the new version because the whole "You have to install all renders again via CCT" worries me when I'm having zero issues with CCT from the most recent update before this one...

Edited by Clarityman
for clarity

Share this post


Link to post
Share on other sites
TheVisitorX
16 minutes ago, Clarityman said:

This was going to be my exact advice too. I've had zero problems with the 1.3.0.0 update because I just deleted many of the old renders from the mods folder, and installed updated renders with the new method. It's worked flawlessly.

I'm actually holding off installing the new version because the whole "You have to install all renders again via CCT" worries me when I'm having zero issues with CCT from the most recent update before this one...

If you have no problems with your current renders, you don't have to uninstall your renders. The method is the same as before. It just changes the references in the ltag files for newly installed renders.

Edited by TheVisitorX

Share this post


Link to post
Share on other sites
Clarityman
2 minutes ago, TheVisitorX said:

If you have no problems with your current renders, you don't have to uninstall your renders. The method is the same as before. It just changes the references in the ltag files for newly installed renders.

Right, I understand. But if I wanted to update a render I installed recently, I'd now have to delete the installed render in the mods folder from the newer method, or risk it reading from that one instead... at this point, I'm just going with the "if it ain't broke, don't fix it" mindset on my end, although I'm sure I'll need to update eventually to benefit from other fixes.

Share this post


Link to post
Share on other sites
TheVisitorX
15 minutes ago, Clarityman said:

Right, I understand. But if I wanted to update a render I installed recently, I'd now have to delete the installed render in the mods folder from the newer method, or risk it reading from that one instead... at this point, I'm just going with the "if it ain't broke, don't fix it" mindset on my end, although I'm sure I'll need to update eventually to benefit from other fixes.

No, you don't have to. Neither if you install a new render nor if you overwrite an existing one you have to delete something. Between the two versions, there are no differences in the render-creation. The only difference is that - from now on - additionally the reference in the original ltga_typeX pac file is deleted. That's all.

Deletion is only relevant for the following case:

- You have additional ltag files outside the normal game folder (old CCT releases did create that)
- Your old render was created with older versions of CCT

* with 'old' I do not mean the previous release

Edited by TheVisitorX
  • Too Sweet 1

Share this post


Link to post
Share on other sites
Clarityman
On 5/31/2019 at 4:33 PM, TheVisitorX said:

No, you don't have to. Neither if you install a new render nor if you overwrite an existing one you have to delete something. Between the two versions, there are no differences in the render-creation. The only difference is that - from now on - additionally the reference in the original ltga_typeX pac file is deleted. That's all.

Deletion is only relevant for the following case:

- You have additional ltag files outside the normal game folder
- You old render was created with older versions of CCT (with old I do not mean the previous release)

Ohhhh wow. I didn't realize. Now THAT is interesting... and good to know! Thanks!

EDIT: Actually, it was exactly what I thought because all my old renders are from the older versions of CCT, but it's still good to know the new method doesn't fundamentally interfere with me just deleting old renders from the mods folder to install updated ones.

Edited by Clarityman

Share this post


Link to post
Share on other sites
BlackBen83
On 5/31/2019 at 1:31 PM, TheVisitorX said:

Please try to delete your whole CCT mod directory and install all renders and things again (re-generate your chunk cache before you do this). Make sure that you haven't any other render mods installed from other sources which could interfere with the renders used from CCT. That the render of Cole is blank makes no sense to me. He has a completely different slot id. Sure, you did not accidentally replace it with a wrong dds file?

@TheVisitorX I'm currently working on it, I leave you feedback soon :) 

I think my problem came from I have used first Wrestle+, and CCT since many months now (I try to desintall Wrestle+, I wish doesn't have the Wrestle+ loading screen). Certainly they interfere together.

And I think "verifiy my WWE2k19 files" too, because my game doesn't launched.

I need to desinstall the game? or just doing other things to fix this problem?

Thanks for your advice.

Edited by BlackBen83

Share this post


Link to post
Share on other sites
TheVisitorX
1 hour ago, BlackBen83 said:

@TheVisitorX I'm currently working on it, I leave you feedback soon :) 

I think my problem came from I have used first Wrestle+, and CCT since many months now (I try to desintall Wrestle+, I wish doesn't have the Wrestle+ loading screen). Certainly they interfere together.

And I think "verifiy my WWE2k19 files" too, because my game doesn't launched.

I need to desinstall the game? or just doing other things to fix this problem?

Thanks for your advice.

No, you don't have to uninstall the complete game. Actually the "verfify game files" function in Steam should be sufficient, but this does not delete any mod directories.

Edited by TheVisitorX
  • Like 1

Share this post


Link to post
Share on other sites
BlackBen83
6 minutes ago, TheVisitorX said:

No, you don't have to uninstall the complete game. Actually the "verfify game files" function in Steam should be sufficient, but this does not delete any mod directories.

I'm verifying the game files. I've uninstall Wrestle+ and I've seen that curiously in my main game folder (a pics of Wrestle+ that I've delete but still in the "desk basket").

Quote

qcbd2r9idzxgbi1zg.jpg

 i'll try to relaunch the game without CCT first. I tell you in a few minutes what happen.

Ben

 

Edited by BlackBen83

Share this post


Link to post
Share on other sites
BlackBen83

@TheVisitorX Ok the game works fine, I have deleted all CCT renders in mod folder :) now I've the render HD original pack made by Stratus.

I'll try to re-inject now all my renders, I leave you feedback for sure.

Thanks again.

Share this post


Link to post
Share on other sites
TheVisitorX
18 minutes ago, BlackBen83 said:

@TheVisitorX Ok the game works fine, I have deleted all CCT renders in mod folder :) now I've the render HD original pack made by Stratus.

I'll try to re-inject now all my renders, I leave you feedback for sure.

Thanks again.

Please beware that any other render pack could cause issues if you try to overwrite one of this renders with CCT. Only renders with the same path and filename are compatible with CCT. Because if you have the same render multiple times in your game dir/chunk file the game will only use one of this. In that case, you have to delete the overlapping render manually. 

  • Like 1
  • Yes! 1

Share this post


Link to post
Share on other sites
BlackBen83
2 minutes ago, TheVisitorX said:

Please beware that any other render pack could cause issues if you try to overwrite one of this renders with CCT. Only renders with the same path and filename are compatible with CCT. Because if you have the same render multiple times in your game dir/chunk file the game will only use one of this. In that case, you have to delete the overlapping render manually. 

That's I've done, I'm re-injecting one by one all my renders.

Share this post


Link to post
Share on other sites
DDK78

Hello

I've been having problems with some renders before AND after the CCT update. Certain renders just either dont appear after injecting or just either the A or B render will appear. Then after I restart game some renders that didnt appear before can be seen but others that worked before wont. Ive deleted these renders and reinjected them multiple times and still no change,

The characters slots im having problems with are

Braun Stroman Dean Ambrose Bobby Roode Pete Dunne and Bobby Lashley all of them in their default slots. Have a CM Punk mod in the 706 (Rick Martel) slot and also have disappear and reappearing renders there too. Bobby Lashley render has never worked

Is there something doing wrong? Like I said the update didnt help me here and I dont want to delete renders that do work in case if I try to reinject them they might stop working too

 

Edited by DDK78

Share this post


Link to post
Share on other sites
BlackBen83

@TheVisitorX Ok the game works really fine :) 

I've finished to inject all my new renders in CCT mod folder.

Some renders aren't inject because I think the Stratus pack for example has been copied in my "assets" game folder (renders), so.

The last question, it's possible to delete the Stratus renders in the main game folder? After that I'll clear chunk and regenerate the chunk, It'll work fine? Because the new personal renders injections has been made with CCT :) and now I've the renders numbers pac.files in CCT folder.

Thanks 

Ben

Edited by BlackBen83

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.