Sign in to follow this  
Broskinator97

Fps issue

Recommended Posts

Broskinator97

For who already has the game, is it normal that my game doesn't go over 45 fps even in window mode? Every other game goes to 60Fps with every settings in mid-high

Share this post


Link to post
Share on other sites
Jimmycrane1986

I have a i7 4790 3.6ghz 8gb of ram and a gtx 980 graphics card and been trying to play at 4k resolution and it's only giving me 13 fps in entrances and 15fps in-game. WWE 2K16 2K17 at same settings i get 60fps

Share this post


Link to post
Share on other sites
GS1981

there is a 21:9 issue also with transparent black bars

i'm running 30fps in menus and entrances 60fps in game (gtx 1080)

Share this post


Link to post
Share on other sites
Broskinator97

I don't understand why when I put the game on windowed mode it goes decently (2k17 went to stable 60fps) at 45/46 fps, but if I put it full screen with the same settings it can't get over 23 fps. It's not possible that I have to play a game not on full screen because they can't do things like they should. Every single other game runs on 60 FPS without a single lag,is it so difficult for 2K to make the same thing?

Share this post


Link to post
Share on other sites
El Buvor

Yep, I also have several performance problems, no problem in 2k15/16/17, we'll see if they optimize the game soon...

Share this post


Link to post
Share on other sites
motishow

Another year with bad optimization game. that sucks!!!!!

Share this post


Link to post
Share on other sites
Broskinator97

I hope they fix it soon, it's impossible to play in this way

Share this post


Link to post
Share on other sites
DrinkingCurly

Had massive FPS drops, but was able to find a fix for my pc. I had to turn display graphics to 1280 x 720, turn off vsync, depth of field & blurr. Got the game running nice and smoothly so probably some optimization will be taking place 

Share this post


Link to post
Share on other sites
4 Life

Ran 2K17 on high settings and nice framerate also, only getting 40fps on much lower settings on 2K18.

Share this post


Link to post
Share on other sites
Youngmeezy

Yeah its absolutely dismal. Have you tried going to config and put numerator and denominator to 60?

Share this post


Link to post
Share on other sites
Apost Khan

It's running solid 60 for me on my 8gb RX 480 with my new Ryzen cpu (except in 8 man matches), but the game is def extremely demanding. It seems to have some kind of low level SSAO baked in with no way to turn it off. So unless you have at least a 1060, maybe even a 1070, I don't see you getting 60fps.

Edited by Apost Khan

Share this post


Link to post
Share on other sites
olympic_hurz

same experience here (i7 4970 / gtx 970 / 16 gb ram / g-sync monitor wth wqhd resolution): never had issues with any other game stuttering so far, maybe especially because of g-sync, but this game is getting me nuts. every movement seems to be a stutter even in one on one matches with fps between 40-50 fps (v-sync because of g-sync) in already reduced settings. there must be a problem with the optimization and a patch is absolutely necessary... 

EDIT: even with mid or low textures the fps rate is varying around 40-50 and the movements look, like they have been cut in between. as is said, i am used to gysnc-flawless graphics and this is a desaster

Edited by olympic_hurz

Share this post


Link to post
Share on other sites
Cave Waverider
35 minutes ago, olympic_hurz said:

same experience here (i7 4970 / gtx 970 / 16 gb ram / g-sync monitor wth wqhd resolution): never had issues with any other game stuttering so far, maybe especially because of g-sync, but this game is getting me nuts. every movement seems to be a stutter even in one on one matches with fps between 40-50 fps (v-sync because of g-sync) in already reduced settings. there must be a problem with the optimization and a patch is absolutely necessary... 

EDIT: even with mid or low textures the fps rate is varying around 40-50 and the movements look, like they have been cut in between. as is said, i am used to gysnc-flawless graphics and this is a desaster

Which driver version are you on? Try the GeForce 387.98 Hotfix driver (use the latest version of Display Driver Uninstaller first to get rid of all remnants of older drivers). The hotfix driver fixes several GSync issues (not just the ones mentioned) and might help you as well. Earlier drivers had all kinds of problems with GSync in some applications and games for me as well.

  • What? 1

Share this post


Link to post
Share on other sites
Kopmeister

Yup hitting 30-40 fps maxed out at 1080p (motion blur disabled, hate it), terribly optimised. The game almost plays in slow motion for some reason. Just had a match in COM Miz purposely played for the count, never seen that happen, granted I haven't played since 2K16. Regretting getting this years 

Share this post


Link to post
Share on other sites
olympic_hurz
17 hours ago, Cave Waverider said:

Which driver version are you on? Try the GeForce 387.98 Hotfix driver (use the latest version of Display Driver Uninstaller first to get rid of all remnants of older drivers). The hotfix driver fixes several GSync issues (not just the ones mentioned) and might help you as well. Earlier drivers had all kinds of problems with GSync in some applications and games for me as well.

Thank you! I did not know, that there is driver hotfix so far. Will try this in the afternoon...  

Share this post


Link to post
Share on other sites
olympic_hurz
On 18.10.2017 at 2:53 PM, Cave Waverider said:

Which driver version are you on? Try the GeForce 387.98 Hotfix driver (use the latest version of Display Driver Uninstaller first to get rid of all remnants of older drivers). The hotfix driver fixes several GSync issues (not just the ones mentioned) and might help you as well. Earlier drivers had all kinds of problems with GSync in some applications and games for me as well.

I just installed the new driver version you posted and ddu'd the older driver, which was i think 387.89.

Sadly it did not solve the problem for me: still have around 45 fps (no v-sync, everything else on high, as i never had problems with a game on 45 fps with g-sync on) but it seems, as some frames are just left out, so that the movements look like torn apart. f.e. when the wrestler walks through the ring, suddenly is in another position, but the animation of his movement is not completely shown so it feels like stuttering. i hope you know what i mean and maybe have another advise?!

EDIT: strangely the benchmark-test within the game is also running like in slow-motion, but this time the movements are not torn apart but slowed down i think 50 percent... what is wrong here...

Edited by olympic_hurz

Share this post


Link to post
Share on other sites
Lorddevil2

My experience with the game is fine. I get solid 60 fps in gameplay (in all match types included 8 man matches). 

My rig

i7 7700 

RX 480 8 GB DDR5 Sapphire

16 GB DDR4

Share this post


Link to post
Share on other sites
olympic_hurz
11 minutes ago, Lorddevil2 said:

My experience with the game is fine. I get solid 60 fps in gameplay (in all match types included 8 man matches). 

My rig

i7 7700 

RX 480 8 GB DDR5 Sapphire

16 GB DDR4

so you have amd.... hmmm, i think this might be about nvidias gsync...

Share this post


Link to post
Share on other sites
Nikolasgr

also in amd there are a lot of problems 45 fps in royal ruble i go with 1600x900 and runs fine his pc has latest on so it pretty much would run fine

Share this post


Link to post
Share on other sites
rodneyexiii

I fell all your pain right now.  I am at the point where a game breaking bug that has stopped me from playing the game.  Every time I try to wrestler a match in universe mode with a CAW, the game crashes.  Second I cant even change the resolution in the game or use windowed.  Every time I change the resolution and apply the changes, once I leave that menu, they are reverted back to where they where.

I am running a build that should by no means have any issue of playing this game.

CPU: I7700k

GPU: GTX 1080TI

16 GB DDR4

By all accounts my PC is a over kill for this game. Guess I will be stuck with wwe 2k17 for the time being, or better yet, just get my money back for the broken game, when I cant even change the options in the menu.

Share this post


Link to post
Share on other sites
Mr.47

SO my specs: GTX 1060 6GB

                        i5 7400

                        16GB DDR4 2400

                       Gigabyte gaming B8 b250

                       DELL SE2216H 1080p

                       Running WWE 2k18 maxed out setting

on 18th oct  and 19th oct i played WWE 2k18 in benchmarks and in 6man or 8man matches i got constant 60fps 1080P in gameplay.. but today 20th oct when i played the game i got about 45fps at 1080P in 6man and 8man matches even in benchmark and i donno why this happened, i tried restarting my pc multiple time updating and downgrading nvidia drivers even game ready drivers. i tried reinstalling the game even,deleting save files, enabling fast sync and disabling vsync, i messed with configs and graphics settings also,but didn't got any results, i checked other games were all fine with the same fps i used to get earlier...

HELP PLEASE.. i am not getting any fix for this bullshit

Share this post


Link to post
Share on other sites
Titavius

I think this is an issue they're well aware of. I'm benchmarking at 29FPS with a 1060 6gb. We shouldn't have to be messing around with the settings in order to make it playable. I would expect them to address it relatively soon.

Edited by Titan83

Share this post


Link to post
Share on other sites
Just Not

gtx 1070 - never had a problem running any game. Until 2k18. Happily sticking with 2k17 for the time being.

Share this post


Link to post
Share on other sites
Mr.47

                        specs:  GTX 1060 6GB

                        i5 7400

                        16GB DDR4 2400

                       Gigabyte gaming B8 b250

                       DELL SE2216H 1080p

                       Running WWE 2k18 maxed out setting

Okay again i am getting 60fps again, I just ran the game and without closing it i just pressed the reset button(not to restart from windows option)

and before playing the game i shut it down and power it on and disable the internal i5 7400 graphics and when i booted back to os and run the game benchmarks i again got 60fps, and in all 8man and 6man matches, but sure 2k should have a patch for this cause i cant do the same thing all the time it goes wrong..

Share this post


Link to post
Share on other sites
Cave Waverider
2 hours ago, Mr.47 said:

                         specs:  GTX 1060 6GB

                        i5 7400

                        16GB DDR4 2400

                       Gigabyte gaming B8 b250

                       DELL SE2216H 1080p

                       Running WWE 2k18 maxed out setting

Okay again i am getting 60fps again, I just ran the game and without closing it i just pressed the reset button(not to restart from windows option)

and before playing the game i shut it down and power it on and disable the internal i5 7400 graphics and when i booted back to os and run the game benchmarks i again got 60fps, and in all 8man and 6man matches, but sure 2k should have a patch for this cause i cant do the same thing all the time it goes wrong.

Turning off internal graphics is a good idea, though, as mixed graphics technology like it can slow down

Just so people don't try this. It's a bad idea to do hard reset (or hard shutdown) from within Windows, it can (and likely will) corrupt your Data and thus lead to problems if not immediately, then later. If you need to get into the BIOS, Hold down SHIFT while clicking on Restart in Windows. There you can select to go to BIOS/Firmware.

The game was likely using the Intel Graphics when you had bad performance. I recommend turning this off, unless you're on a laptop and want to use internal graphics when doing non-demanding tasks on battery (then you'll have to create an Optimus profile for WWE 2k18 in the Nvidia Drivers which don't come with one for WWE games and force it to use the Dedicated Nvidia GPU in it). 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this